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Introduction
Microsoft® Office Web Apps is the online companion to Microsoft Word, Microsoft Excel®, Microsoft
PowerPoint®, and Microsoft OneNote® applications that helps users access documents from almost
anywhere. Users can view, share, and work on documents online with other users across personal
computers, mobile devices, and the web.
Office Web Apps is available to users through Microsoft SharePoint® Online, which is part of Microsoft
Office 365. Office Web Apps is also available as a part of Microsoft Windows Live™ and also to business
customers through Microsoft Office 2010 volume licensing, Office 365, and document management
solutions based on Microsoft SharePoint 2010 products.
This document focuses on using Office Web Apps as a part of SharePoint Online.
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Features of Microsoft Office 365
Microsoft Office Web Apps is one of several cloud services offered by Microsoft Office 365 for
enterprises. These Internet-based services are designed to help meet the need for robust security, 24/7
reliability, and user productivity.
Each service is designed for reliability, availability, and performance with a financially backed service
level agreement (SLA) for a guaranteed 99.9-percent scheduled uptime. Microsoft deploys patches,
security updates, and back-end upgrades, helping to eliminate the time and effort organizations spend
managing their servers.
Subscribers to Office Web Apps benefit from a set of features that are common to all of the Microsoft
business-class cloud services:
















Secure access: Each offering from Microsoft Office 365 is accessed through 128-bit Secure
Sockets Layer (SSL) or Transport Layer Security (TLS) encryption. Anyone who intercepts a
communication sees only encrypted text.
Intrusion monitoring: Microsoft continuously monitors the Office 365 systems for any unusual
or suspicious activity. If Microsoft detects such activity, it investigates and responds
appropriately. In the unlikely event that a significant incident occurs, the customer is notified.
Security audits: Microsoft regularly assesses the Office 365 infrastructure to ensure that the
latest antivirus signatures and required security updates are installed, and that high-level
configuration settings are in compliance with Microsoft security policies. For details, refer to the
Security and Service Continuity for Enterprises Service Description .
High availability: Microsoft Office 365 services have a 99.9-percent scheduled uptime. If a
customer’s service is affected, Office 365 offers financial remedies subject to the terms and
conditions of the SLA. For details, refer to the Service Level Agreement for Microsoft Online
Services.
Service continuity: Redundant network architecture is hosted at geographically dispersed
Microsoft data centers to handle unscheduled service outages. Data centers act as backups for
each other: If one fails, the affected customers are transferred to another data center with
limited interruption of service.
Microsoft Online Services Portal: This easy-to-use website is the center for activities related to
Microsoft Office 365. The portal provides services based on each organization’s specific needs.
Prospective subscribers can use the portal to sign up for a free trial. End users accessing the
portal can find online help, open Microsoft SharePoint site collections, and launch Microsoft
Outlook® Web App. Administrators can manage users, administer services, download tools, and
learn about service administration from online help.
Directory Synchronization tool: For subscribers with Active Directory® directory services
deployed on-premises, this tool helps keep the on-premises Active Directory and the Microsoft
Office 365 directory synchronized.
Remote administration: With Microsoft Windows PowerShell™, administrators can perform
many tasks using a script or automated process. For example, tasks such as creating users,
resetting passwords, assigning licenses, and obtaining service-use data can be fully automated.
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Office Desktop Setup
For the best experience with Office 365, a set of required components and updates must be applied to
each workstation. To simplify the installation and maintenance of these components and updates,
Microsoft provides an installable piece of software—called Office desktop setup—at no charge. These
updates are required for all workstations that use rich clients (such as Microsoft Office 2010) and
connect to Microsoft Office 365.
Office desktop setup provides multiple benefits, including:





Automatically detecting necessary updates
Installing updates and components upon approval or silently from a command line
Automatically configuring Outlook and Microsoft Lync for use with Microsoft Office 365
Uninstalling itself from the client computer after running

A list of these update requirements are available for companies that want to use an alternative method
of deploying the updates. See the help topic Manually update and configure desktops for Office 365 for
details.
Note

Office desktop setup is not an authentication or sign-in service and should not be confused with single
sign-on.

Federated Identity and Single Sign-On
With on-premises Active Directory, administrators can use a single sign-on approach to Office 365
authentication. To achieve this, administrators can configure on-premises Active Directory federation
Services—a Microsoft Windows Server® 2008 service—to federate with the Microsoft Federation
Gateway. After Active Directory Federation Services is configured, all Office 365 users whose identities
are based on the federated domain can use their existing corporate logon to automatically authenticate
to Office 365.

System Requirements
Table 1 shows the software required to access Microsoft Office 365—including Office Web Apps
Table 1: Software supported by Microsoft Office 365
Software

Supported Version

Operating systems

Windows 7

®

®

Windows Vista Service Pack 2
Windows XP Service Pack 3
Macintosh OS X 10.5 (Leopard), 10.6 (Snow Leopard)
Windows Server 2008
System software

Microsoft .NET Framework 3.0 (for Windows XP)
Java client 1.4.2 (for Macintosh OS X)*
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Software

Supported Version

Office clients

Microsoft Office 2010 or Office 2007 Service Pack 2
®

Office 2008 for Mac and Microsoft Entourage 2008 Web Services Edition
Office 2011 for Mac and Outlook 2011 for Mac
.NET Framework 2.0 or later
Microsoft Lync Client 2010
Client applications

Office desktop setup

Browser software—Microsoft Internet Explorer 7 or later
Online Services Portal
Mozilla Firefox 3.x
Apple Safari 3.x
Browser software—
Outlook Web App

Internet Explorer 7 or later
Firefox 3 or later
Safari 3 or later on Macintosh OS X 10.5
Chrome 3 and later versions
Outlook Web App also has a light version that supports a reduced set of features across
almost any browser

International Availability
Office 365 is available in Austria, Belgium, Canada, Colombia, Costa Rica, Cyprus, Czech Republic,
Denmark, Finland, France, Germany, Greece, Hong Kong, Hungary, India, Ireland, Israel, Italy, Japan,
Luxembourg, Malaysia, Mexico, Netherlands, New Zealand, Norway, Peru, Poland, Portugal, Puerto Rico,
Romania, Singapore, Spain, Sweden, Switzerland, Trinidad and Tobago, United Kingdom, and United
States.
Multinational customers that purchase services in an approved country may enable use by their end
users that reside anywhere in the world, except for Argentina and countries currently embargoed by the
U.S. government. Features availability may vary by location. See the help topic License restrictions for
Office 365 for details.

Data Center Locations
Microsoft Office 365 maintains primary and backup data centers distributed around the world. When a
company signs up for a Microsoft Office 365 service, its hosted environment is automatically provisioned
in the appropriate data center based on the company’s address. All users for the company are hosted
from the same data center.

Localization
Table 2 summarizes the languages supported the Microsoft Office 365 platform and related
components.
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Table 2: Supported languages for components related to Microsoft Office 365
Component

Supported languages

Microsoft Online Services Portal

Brazilian Portuguese, Chinese Traditional, Czech, Danish, Dutch, English,
1
Finnish, French, German, Greek, Hungarian, Italian , Japanese, Norwegian
(Bokmal), Polish, Romanian, Spanish, Swedish

Help content—for end users and IT
professionals

Brazilian Portuguese, Chinese Traditional, Czech, Danish, Dutch, English,
Finnish, French, German, Greek, Hungarian, Italian, Japanese, Norwegian
(Bokmal), Polish, Romanian, Spanish, Swedish

Directory Synchronization Tool

Brazilian Portuguese, Chinese Traditional, Czech, Danish, Dutch, English,
Finnish, French, German, Greek, Hungarian, Italian, Japanese, Norwegian
(Bokmal), Polish, Romanian, Spanish, Swedish

Technical Support
The Microsoft Office 365 technical support team provides supports services to people with
administrator permissions for their company’s Office 365 services. Those with administrator permissions
provide support services to their company’s Office 365 end users. For contact information, see Online
Help in the services Administration Center.

Subscription Plans
Each Office 365 user who accesses the Office Web Apps must be assigned to a subscription plan. Office
Web Apps are available to users that are assigned the following SharePoint Online standalone plans:



SharePoint Online (Plan 1)
SharePoint Online (Plan 2)

Office 365 Suite Subscription Plans
Office Web Apps are also available as part of an Office 365 suite subscription. Tables 3 and 4 summarize
the Office 365 plans and show which plans include Office Web Apps. To determine which plan is right for
you, visit www.office365.com.
Table 3: Office 365 subscription plans for kiosk workers
Office 365 (Plan K1)

Office 365 (Plan K2)

Exchange Online Kiosk

Exchange Online Kiosk

SharePoint Online Kiosk

SharePoint Online Kiosk
Office Web Apps
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Table 4: Office 365 subscription plans for information workers
Office 365 (Plan E1)

Office 365 (Plan E2)

Office 365 (Plan E3)

Office 365 (Plan E4)

Exchange Online (Plan 1)

Exchange Online (Plan 1)

Exchange Online (Plan 2)

Exchange Online (Plan 2)

SharePoint Online (Plan 1)

SharePoint Online (Plan 1)

SharePoint Online (Plan 2)

SharePoint Online (Plan 2)

Lync Online (Plan 2)

Lync Online (Plan 2)

Lync Online (Plan 2)

Lync Online (Plan 2)

Office Web Apps

Office Web Apps

Office Web Apps

Office Professional Plus

Office Professional Plus
Lync Voice & PBX (Lync Plus
CAL for Lync Server)*

* Lync Voice & PBX are only available with Lync Server 2010, deployed on-premises or hosted via a private cloud deployment. All Lync
workloads (IM, online meetings and Voice & PBX) must be deployed on Lync server in this case (it is not possible to split Lync workloads
between Lync Server and Lync Online).
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Benefits of Office Web Apps
With Office Web Apps, people can work with confidence using familiar tools that can help to increase
flexibility and productivity. This section discusses specific benefits in greater detail.

Never Be Without Tools
Workers need access to the tools they use, whenever and wherever they want. They may be away from
the office or home when new data comes in—only to realize that the computers they can access do not
have Microsoft Office 2010 installed. With Office Web Apps, users can create content in Word, Excel,
PowerPoint, and OneNote on their desktops and post it to Microsoft SharePoint 2010 sites, SharePoint
Online, or Microsoft Windows Live SkyDrive™ folders. They then can access, view, edit, and share those
files from almost any computer with an Internet connection. Users can even access and view
PowerPoint, Word, and Excel content from a browser on mobile devices.
Note

Supported mobile viewers for Microsoft Word, Excel, and PowerPoint Web Apps on SharePoint 2010
include Internet Explorer on Windows Mobile 5 or later, Safari 4 on iPhone 3G or 3GS, BlackBerry 4.x
and later, Nokia S60, NetFront 3.4, 3.5 and later, Opera Mobile 8.65 and later, and Openwave 6.2, 7.0
and later.

Ensure High-Fidelity, Consistent Views
Workers spend a lot time making all their content look its best. Therefore, it would be reassuring to
know that those who view their documents, presentations, workbooks, and notebooks will see the
content as intended. Office Web Apps provides professional, high-fidelity viewing of Word, Excel,
PowerPoint, and OneNote files. Users can take advantage of the rich features in Microsoft Office on
their desktops to create content and then share those files online with great document fidelity and
consistent formatting.
Note

Microsoft Silverlight™ is not required for any functionality but is recommended for best results when
viewing PowerPoint and Word documents in Office Web Apps.

Edit Content with Confidence
When workers create documents with Microsoft Office on their desktops, they might use rich content
and advanced features—such as graphics, images, tables of content, and cross-references—to add
impact to their important information. Office Web Apps enables users to open the documents that are
created in Microsoft Office on their computers, make light edits on the web, and open them again in
their desktop applications to seamlessly continue editing with full access to rich features and tools.
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Work More Easily with Others
Some team members may use Microsoft Office on a Microsoft Windows PC and others may use Office
on Apple Macintosh computer. To make collaboration easier, teams need a common set of tools to
easily share and edit content. Office Web Apps provides these tools, helping to simplify collaboration
with people who use different platforms and different versions of Microsoft Office. With Office Web
Apps, people can even work with others who do not have Microsoft Office on their computers. People
who share access to files can edit them easily and instantly from supported web browsers on a PC or
Macintosh.
Note

Supported browsers include Internet Explorer 7 or later for Windows, Safari 4 or later for Mac, and
Firefox 3.5 or later for Windows, Mac, or Linux.

Get Started Right Away
In today’s fast-paced business environment, workers can save time with a web-based solution—as long
as it is easy to adopt and use. With Office Web Apps, people can work in a familiar environment, using
several of the same editing and formatting features they already know from Microsoft Office.

Microsoft Office Web Apps Service Description

12

Office Web Apps Service Details
As the online companion to Microsoft Word, Excel, PowerPoint, and OneNote, Office Web Apps enables
users—regardless of their location—to access and edit documents. Users can view, share, and work on
documents with others online across personal computers, mobile phones, and the web. Office Web
Apps is available through Windows Live and Office 365 as a part of SharePoint Online , and to business
customers with Microsoft Office 2010 volume licensing and document management solutions based on
Microsoft SharePoint 2010 products.
Note

An appropriate device, an Internet connection, and a supported Internet Explorer, Firefox, or Safari
browser are required. Some mobile functionality requires Microsoft Office Mobile 2010, which is not
included in Office 2010 applications, suites, or Web Apps. There are some differences between the
features of Office Web Apps, Office Mobile 2010, and the Office 2010 applications.

Versions
Office Web Apps is available to consumers and business customers through:





Office 365: Office Web Apps is included in Office 365 licenses that include SharePoint Online.
On-premises: Business customers licensed for Microsoft Office 2010 through a volume licensing
program can use Office Web Apps on a server that runs Microsoft SharePoint Foundation 2010
or Microsoft SharePoint 2010.
Windows Live: For consumers and small-business users, Office Web Apps is available on
Windows Live as a free service.

The experience within Office Web Apps is generally consistent whether being used from SharePoint
Online, an on-premises SharePoint 2010 server, or Windows Live in a browser on a PC or Mac computer.
However, there are differences in the host environments that make SharePoint the preferred experience
for most organizations. Though organizations can use Office Web Apps through Windows Live, most
business customers should consider the benefits of deploying Office Web Apps on SharePoint or using
SharePoint Online—especially if they want to provide Office Web Apps to all employees. Here are some
reasons why:






Familiar SharePoint experience. Office Web Apps on SharePoint 2010 or SharePoint Online: are
best for business customers because they provide the familiar SharePoint experience along with
key enterprise features such as administrator site control, document life cycle functions,
auditing, and backup and restore capabilities.
SLAs: Guaranteed service level agreements (SLAs) are provided as a part of the SharePoint
Online license.
Support: Worldwide support by phone, email, or the Office 365 Administration Console is
provided as part of the SharePoint Online license.
No advertising. Office Web Apps on Windows Live is an ad-supported service.
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System Requirements
This section describes the system requirements to support Office Web Apps.

Browser Support
For an Office Web Apps solution provided by SharePoint Online, all client computer web browsers must
meet minimum version requirements. Office Web Apps is supported in the following browsers:




Internet Explorer 7 and later on Windows operating systems
Safari 4 and later on Mac operating systems
Firefox 3.5 and later on Windows, Mac, and Linux operating systems

Known Browser Issues
When using Office Web Apps, users who click the Open in (Word, PowerPoint, Excel, or OneNote)
button may see a message that states the file cannot be opened in the client application. This can be
caused by one or more of the following conditions:








The user is running a 64-bit version of Internet Explorer.
The ActiveX control necessary for opening the file in the Office client application is not installed
or running in the browser.
Microsoft Office is not installed on the client computer.
The version of Office that is installed is earlier than Office 2003.
Security settings in Internet Explorer are preventing the ActiveX controls from running.
The browser does not support ActiveX.
The client browser is Firefox, but the plug-in that enables Firefox to open Office documents is
not installed.

Mobile Device Support
Users can view Word, Excel, and PowerPoint files using Office Web Apps on most modern smartphones.
For Office Web Apps on SharePoint, the following mobile browsers are supported:








Internet Explorer on Windows Mobile® 5/6/6.1/6.5
Safari4 on iPhone 3G/S
BlackBerry 4.x and later
Nokia S60
NetFront 3.4, 3.5 and later
Opera Mobile 8.65 and later
Openwave 6.2, 7.0, and later

The Apple iPad is supported for viewing Word and PowerPoint files.
To access pages using mobile devices, the URL is identical to that used by browsers running on client
computers. However, this can vary depending on the configuration and presence of web proxies. Users
can click E-mail a Link on the Share and Track tab of the ribbon in SharePoint to receive the address in
email on an SMTP service-enabled SharePoint server.
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Note

Supported browsers include Internet Explorer 7 or later for Windows, Safari 4 or later for Mac, and
Firefox 3.5 or later for Windows, Mac, or Linux.

Localization
Office Web Apps are available in all Office 365 languages.
Office Web Apps generally support documents created in Office 97 and later, with these exceptions:






Older file formats (such as .doc, .xls, .ppt) are automatically converted to Open XML format
(such as docx, .xlsx, .pptx) for editing because Office Web Apps natively supports only the newer
file formats. There is no option to save documents in the binary formats.
The Excel Web App on SharePoint supports only the newer Excel files formats (including .xlsx,
.xlsb, and .xlsm). These can be created in Microsoft Office Excel 2007 or later or using the
compatibility pack with older versions of Excel. The Excel Web App on SkyDrive enables viewing
and editing (after conversion) of older .xls files.
The OneNote Web App supports only files created in Microsoft OneNote 2010 (or the Web App).

Supported File Types
Table 5 describes the supported file types for Office Web Apps.
Table 5: Supported file types
File Type

View

Edit

Word documents created in Word 2.0 or later
Open XML

.docx

Y

Y

Binary

.doc

Y

Converted to .docx

Macro

.docm

Y

Other

.dotm, .dotx

Y

Max file size

No maximum, except SkyDrive (50 MB) and SharePoint (configurable) file size limits

3

Y

3

N

Excel workbooks created in Excel 97 or later
Full support

.xlsx, .xlsb

Y

Y

Binary

.xls

Only in SkyDrive

Only in SkyDrive, converted to xlsx

Macro

.xlsm

Y

Max file size

2 megabytes (MB) for SkyDrive, 10 MB default for SharePoint (admin can configure to up to 2GB)

File Type

3

Y, macros stripped

View

Edit

Y

4

PowerPoint presentations created in PowerPoint 97 or later
Open XML

.pptx , .ppsx

Y

Binary

.ppt, .pps

Y

Macro

.pptm, .potm, .ppam, .potx, .ppsm

Y

Converted to .pptx or .ppsx
3
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File Type
Max file size

View

Edit

None besides SkyDrive (50MB) and SharePoint (configurable) file size limits

OneNote notebooks created in OneNote 2010
Open XML

.one - OneNote 2010

Max file size

None besides SkyDrive (50 MB) and SharePoint (configurable) file size limits

3
4

Y

Y

Macros are not run.
If macros exist, users are prompted to have a copy of the file with the macros removed.

Note

Newer file formats (such as .docx, .xlsx, and .pptx) can be created in Office 2010 or 2007, or in Office
2000 and later with the compatibility pack.

Printing
Users can print from the Word Web App and the PowerPoint Web App. A .pdf reader (such as Adobe
Reader or Foxit) is required. Currently, printing in the PowerPoint Web App is only available on Windows
Live. Alternately, once a document is open in Office Web Apps, users can easily switch to Microsoft
Office and print to any available printer.

Co-Authoring
Co-authoring enables multiple people to simultaneously edit a document at the same time.
Table 6 details support for co-authoring within Office Web Apps and Office 2010.
Table 6: Co-authoring within Office Web Apps
Word

Excel

PowerPoint

OneNote

Office 2010

Yes

No

Yes

Yes

Office Web Apps

No

Yes

No

Yes

User Experience
This section describes how users work with Office Web Apps.

View and Edit Office Documents
Office Web Apps gives users a browser-based viewing and editing experience by providing
representations of Office documents in the browser. When users click a document stored in a
SharePoint document library, the document opens directly in the browser. In the browser, the
document looks similar to how it appears in the Office client application. The Web App also provides
many of the same editing features as the Office client application.
Office Web Apps provides representations of documents, presentations, workbooks, and notebooks
using native browser objects such as HTML, JavaScript, and images. Each document type is handled
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differently depending on which Office Web Apps services are started and whether the Office Web Apps
feature is activated.
A document in the Word Web App, Excel Web App, or PowerPoint Web App can be edited in the
browser or opened for editing in the associated Office client application. While working in a Web App,
users can click the Edit in Browser button on the Home tab to perform light editing tasks in the browser.
For the OneNote Web App, users can edit a notebook in the browser—without having to click the Edit in
Browser button—or they can click Open in OneNote to edit the notebook in the OneNote client
application.
While working in a Web App, users can click the Open in (Word, Excel, PowerPoint, or OneNote) button
to open a document in the associated Office client application (if it is installed on the client computer).

Enhance the Web Experience with Silverlight
Microsoft Silverlight is a plug-in provided at no cost that can enhance the web experience for many
browsers. The Silverlight plug-in is not required to be installed on the client browser to use Office Web
Apps; however, having the Silverlight plug-in can provide the following benefits:




When using the Word Web App on browsers with the Silverlight plug-in installed, users can
experience faster page loads; improved text fidelity at full zoom; ClearType tuner settings
support; and when using the Find on This Page feature, improved accuracy in the location of
search string instances.
When using the PowerPoint Web App on browsers with the Silverlight plug-in installed, users
can experience faster page loads, smoother animations, and presentation slides that scale with
the size of the browser window.

Having Silverlight installed on the client browser does not provide additional benefits in the Excel Web
App or the OneNote Web App. For more information about Silverlight, see Silverlight Home page.

How Web Apps Work
Each Web App uses some or all of the components described in the User Experience section above to
provide a viewable Office document in the browser and an editable document in either the browser or
the client application.

View and Edit Word Documents
For Word document types, the Word Web App uses a combination of images, HTML, and JavaScript to
render documents that users can view. If Silverlight is installed on the client browser, some images will
be displayed using XAML.
When users click a Word document in SharePoint, WordViewer.aspx checks the Office Web Apps cache
to determine whether a rendition of a document is already available if the Default open behavior for
browser-enabled documents setting is set to “open in browser.”
If a rendition of the document is available in the cache, the Word Web App front-end components
display the document in View mode in the browser. If a rendition of the document is not available in the
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cache, the front-end component calls the Word Viewing service application to render the document.
The Word Viewing service application initializes and manages a worker process to render the document
by converting it into a series of .png images or XAML (if Silverlight is installed). The Word Viewing service
application then returns the rendered document to WordViewer.aspx and the cache. WordViewer.aspx
displays the document in the browser in View mode. The Word Viewing service application can initialize
and manage multiple worker processes with each process dedicated to a single session.
While in View mode, if users click the Edit in Browser button on the Microsoft Word Web App toolbar,
WordViewer.aspx goes to the Word Editor (Edit mode). The Word Editor is a web front-end component
that creates a browser-based editing surface, which enables users to work on documents without losing
fidelity.
While in View or Edit mode, if users click the Open in Word button on the Microsoft Word Web App
toolbar, the document opens in the Word client application (if Word is installed on the client computer).

View and Edit Excel Workbooks
The Excel Web App uses DHTML and JavaScript to render Excel workbooks that users can edit without
the need to download ActiveX controls to the browser on the client computer. The Excel Web App uses
Excel Calculation Services to load the workbook; calculate in full fidelity; refresh external data, if needed;
and maintain the session.
When users click an Excel workbook in SharePoint, the Excel Web App uses the Excel Services
Application Web Service Application Proxy to direct calls to and from Excel Calculation Services if the
Default open behavior for browser-enabled documents setting is set to “open in browser.”
While in View mode, if users click the Edit in Browser button on the Microsoft Excel Web App toolbar,
the workbook opens in the browser. The browser sends updates to Excel Calculation Services, which
services those editing requests and returns updated results to the browser.
While in View or Edit mode, if users click the Open in Excel button on the Microsoft Excel Web App
toolbar, the workbook opens in the Excel client application (if Excel is installed on the client computer).

View and Edit PowerPoint Presentations
For PowerPoint presentation types, the PowerPoint Web App uses a combination of images, HTML, and
JavaScript to render presentations that users can view. If Silverlight is installed on the client browser,
some images are displayed using XAML.
When users click a PowerPoint presentation in SharePoint, the PowerPoint Web App front-end
components check the Office Web Apps cache to determine whether a rendition of the presentation is
already available, as long as the Default open behavior for browser-enabled documents setting is set to
“open in browser.”
If a rendition of the presentation is available in the cache, the PowerPoint Web App front-end
components display the presentation in View mode in the browser. If a rendition of the presentation is
not available in the cache, PowerPointFrame.aspx calls the PowerPoint service application to render the
presentation. The PowerPoint service application initializes and manages a worker process to render the
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document by converting it into a series of .png images or XAML (if Silverlight is installed). The
PowerPoint service application then returns the rendered document to PowerPointFrame.aspx and the
cache. PowerPointFrame.aspx displays the document in the browser in View mode. The PowerPoint
service application can initialize and manage multiple worker processes, each process dedicated to a
single session.
While in View mode, if users click the Edit in Browser button on the Microsoft PowerPoint Web App
toolbar, PowerPointFrame.aspx goes to PowerPoint Editor (Edit mode). The PowerPoint Editor is a web
front-end component that creates a browser-based editing surface, which enables users to work on
documents without losing fidelity. PowerPointFrame.aspx sends updates to the PowerPoint service
application—which services editing requests, manages a single worker process for each editing session,
manages re-rendering, automatically saves, and returns the updated rendition to
PowerPointFrame.aspx. PowerPointFrame.aspx then displays the updated rendition of the presentation
in the browser.
While in View or Edit mode, if users click the Open in PowerPoint button on the Microsoft PowerPoint
Web App toolbar, the presentation opens in the PowerPoint client application (if PowerPoint is installed
on the client computer).

View and Edit OneNote Notebooks
The OneNote Web App uses a combination of HTML and JavaScript to render notebooks that users can
view and edit.
When users click a OneNote notebook in SharePoint, OneNote.aspx displays the notebook in the
browser if the Default open behavior for browser-enabled documents setting is set to “open in
browser.” Users can then edit the notebook in the browser.
If users click the Open in OneNote button on the Microsoft OneNote Web App toolbar, the notebook
opens in the OneNote client application (if OneNote is installed on the client computer).

Broadcast Slide Show
Broadcast Slide Show is a new capability in Microsoft Office 2010 that enables presenters to broadcast a
slide show from PowerPoint 2010 to remote viewers who watch in web browsers. Broadcast Slide Show
provides organizations with a low-infrastructure presentation capability that works through the web.
This feature is supported in Office Web Apps and SharePoint Online. For more details, see PowerPoint
Broadcast Slide Show.

Web Apps Features
The specific features and benefits of Word Web App, Excel Web App, PowerPoint Web App, and
OneNote Web App are described in this section. Table 7 describes the features of Word Web App.
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Table 7: Features and benefits of Word Web App
Features and Benefits

Description

Location

Print

Print the active document.

On the command bar, click File and then click
Print.

Find

Search for document text using Word Web
App in View mode. See automatic highlighting
of search hits in the document, along with a
pane showing a summary of search results.
Click any result in the pane to move to that
point in the document.

On the command bar, click Find.

Zoom

Select zoom presets ranging from 50 to 200
percent, as well as Full Page and Page Width
options. Type a custom zoom level between
33 and 400 percent.

Find the zoom level drop-down list on the
command bar.

Navigation

When opening documents in Word Web App
View mode, see the total number of pages in
the document and move through the
document by page or type a number to
immediately go to that page.

On the right side of the command bar, find
the page count and page navigation buttons.

Open in Word

With a single click, continue editing a
document in Word on the desktop.

In Word Web App View mode, find Open in
Word on the command bar or by clicking the
File tab.

Viewing in Word Web App

Note: Microsoft Silverlight is recommended
for the best viewing fidelity when changing
zoom level.

Note: When editing in Word Web App, find
this option on the Home tab, in the Office
group.
Edit in Web App

When viewing a document in Word Web App
View mode, open the document for editing in
the browser with a single click.

On the command bar, click Edit in Browser.

Features and Benefits

Description

Location

Save changes to a document when editing in
Word Web App.

To save a document, use one of the following
procedures:

Editing in Word Web App
Save






On the Quick Access Toolbar, click
the Save button.
On the ribbon, click the File tab, and
then click Save.
Use the CTRL+S keyboard shortcut.

View in Web App

When editing a document in Word Web App,
switch views to see the rich document in high
fidelity at any time.

Save the document to preserve changes.
Then, on the View tab of the Ribbon, click
Reading View.

Clipboard

Cut, copy, and paste content in a document.
Copy and paste text between Web Apps, as
well as between Office Web Apps and the
Microsoft Office programs on the computer.

On the Home tab, in the Clipboard group, find
the Cut, Copy, and Paste commands.
Note: You can also right-click the selected
content and then click Cut, Copy, or Paste

Microsoft Office Web Apps Service Description

20

Features and Benefits

Description

Location

Undo and Redo

Undo or redo recent actions in the active
document.

On the Quick Access Toolbar, click the Undo
and Redo buttons.

Note: You can undo an infinite number of
changes in an active document in the current
editing session in Word Web App Editor—
until the document is saved or a picture is
inserted.

You can also use the CTRL+Z (undo) and
CTRL+Y (redo) keyboard shortcuts.

Font Formatting

Apply font, font size, and several font
formatting attributes—including bold, italic,
underline, and superscript. Highlight text,
change font color, and clear formatting for
selected text.

On the Home tab, find all font formatting
options in the Font group.

Note: Document theme formatting is
available to format text in Word Web App.
Find the active theme fonts at the top of the
Fonts gallery and theme colors in the Font
Color gallery.
Paragraph Formatting

Change paragraph alignment, increase or
decrease the indent from left margin, or
change text direction from left to right.

On the Home tab, find paragraph formatting
options in the Paragraph group.

Bullets and Numbering

Apply a choice of three bullet styles or five
numbering styles. Click the Increase Indent
and Decrease Indent buttons to change the
list level for existing bulleted and numbered
lists in the document, as well as those created
in Word Web App.

On the Home tab, find bullets, numbering,
and the options to change list level in the
Paragraph group.

The paragraph and character styles that are
saved in a document are available to be
applied to text in Word Web App.

On the Home tab, in the Styles group, find
styles that are included in a document’s Quick
Style set (in the Styles gallery).

Styles

Note: Custom bullet and numbering formats
applied in Word on the desktop are retained
in a document when edited in Word Web
App. To view custom number formats in the
document, open it in Word Web App View
mode.

You can also click to expand that gallery for
the Apply Styles option, which provides
access all paragraph and character styles in
the document.
Note: You can also use keyboard shortcut
keys, including CTRL+ALT+1, 2, and 3 (apply
Heading styles) and CTRL+SHIFT+N (apply
Normal style).
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Features and Benefits

Description

Location

Proofing Tools

Word Web App automatically checks spelling
as users type and applies a wavy red
underline to misspelled text. Common
AutoCorrect actions are included, such as
correcting routine misspellings or converting
characters to symbols.

On the Home tab, in the Spelling group, click
Spelling to move to the next spelling error in
the document. A drop-down list of correction
options appears.

Additionally, you can set the proofing
language or turn off the spelling checker for
selected text.

On the Home tab, click the arrow beneath the
Spelling button for Set Proofing Language to
change the proofing language or disable the
spelling checker.

Insert a table, edit table text, and easily edit
basic table structure, such as adding or
deleting rows and columns.

To insert a table, click the Insert tab. In the
Tables group, click Table. Then, point to the
grid to select the desired number of columns
and rows and click to insert.

Tables

You can also right-click a misspelled word to
access correction options.

To edit table structure, click in a table. The
Table Tools Layout tab appears automatically,
providing options to select, delete, and insert
table elements and to align content in cells.
You can also right-click in a table for table
editing options.
Pictures

Insert a picture from a file or from Office.com
Clip Art. You can also resize pictures and add
alternative text.

To insert a picture, click the Insert tab. In the
Picture group, click Picture or click Clip Art.

Hyperlinks

Insert a hyperlink to a web address or apply a
link to selected text.

Click the Insert tab. In the Links group, click
Link.

Placeholders

Word Web App in Edit mode automatically
displays placeholders for features it cannot
display, such as SmartArt graphics, Excel
charts, and content controls. Placeholders
preserve the layout and rich content in a
document and help users navigate a file when
making edits in Word Web App.

Placeholders for objects that cannot be
displayed appear automatically.

To resize a picture or add alternative text,
select the picture. The Picture Tools Format
tab provides these options whenever a
picture is selected.

To view the rich content that is shown as
placeholders in Word Web App Edit mode, on
the View tab, click Reading View.
You can also click the Home tab, and then
click Open in Word.

Table 8 describes the features and benefits of Excel Web App.
Table 8: Features and benefits of Excel Web App
Features and Benefits

Description

Where to Find

Refresh data connections for the entire
workbook or a selected PivotTable, or
recalculate the workbook.

On the command bar, click Data.

Viewing in Excel Web App
Refresh Data

Note: When editing in Excel Web App, you
can find these options on the Home tab, in
the Data group.
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Features and Benefits

Description

Where to Find

Find

Find cell content in the active worksheet. An
easy-to-use dialog box gives the option to
search up or down from the current selection
in the worksheet.

On the command bar, click Find.

Navigation

Click a sheet tab to move to a different
worksheet. Click row or column headings to
select that row or column, and use the arrow
keys to move through the worksheet.

Access sheet tabs as well as row and column
headings when viewing or editing a workbook
in Excel Web App.

Open in Excel

With one click, you can continue editing a
workbook in Excel on the desktop.

In Excel Web App view mode, find Open in
Excel on the command bar or by clicking the
File tab.

Note: When editing in Excel Web App, you
can access this command on the Home tab, in
the Data group.

Note: In Excel Web App Edit mode, you can
access this command on the Home tab, in the
Office group.
Edit in Web App

When viewing a workbook in Excel Web App
View mode, you can open the workbook for
editing in the browser with a single click.

On the command bar, click Edit in Browser.

Sort and Filter Data

Sort and filter data in Excel tables and
PivotTable views.

Click the AutoFilter arrows on headings in a
table or PivotTable for sort and filter options.
Note: This feature is also available when the
workbook is open for editing in Excel Web
App.

Save or Download a Copy

Features and Benefits

From the File tab in Excel Web App View or
Edit mode, you can create a copy of the
workbook and download either a complete
copy or just a snapshot—a file containing only
the values and formatting from the
workbook.

In Excel Web App View mode, click the File
tab on the command bar.

Description

Where to Find

Simultaneously edit a workbook with people
in other locations.

Open a workbook for editing in Excel Web
App. When someone else opens the same
workbook for editing in Excel Web App,
simultaneous editing begins automatically.

In Excel Web App Edit mode, click the File tab
on the ribbon.

Editing in Excel Web App
Co-authoring

View who else is editing the file on the right
side of the Status bar at the bottom of the
screen.
Note: See changes that others make
automatically. Changes synchronize in near
real time.
Save

When you open a workbook for editing in
Excel Web App, the workbook is automatically
saved as you work.

Saving is automatic in Excel Web App.
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Features and Benefits

Description

Where to Find

Clipboard

Cut, copy, and paste content in a workbook.
You can copy and paste text between Web
Apps, as well as between Office Web Apps
and the Microsoft Office programs on the
computer.

On the Home tab, in the Clipboard group, find
the Cut, Copy, and Paste commands.

Undo or redo up to the last 25 actions taken
during the current editing session in the
active workbook.

On the Quick Access Toolbar, click the Undo
and Redo buttons.

Undo and Redo

Note: You can also use the keyboard
shortcuts: CTRL+C (copy), CTRL+X (cut), and
CTRL+V (paste).

You can also use the CTRL+Z (undo) and
CTRL+Y (redo) keyboard shortcuts.
Formula Bar

Just as in Excel on the desktop, you can edit
text and formulas either directly in the
worksheet cell or in the Formula Bar. Use the
Formula Bar to easily see and edit cell
formulas when the result is displayed in the
selected cell.

Find the formula bar directly below the
ribbon.

Font and Cell Formatting

Apply font, font size, and several font
formatting attributes, including bold, italic,
underline, and double underline. Also apply
cell borders and shading.

On the Home tab, find all font and cell
formatting options in the Font group.

Note: Active theme colors are available for
text and cell fill in Excel Web App. Find theme
colors in the Font Color and Fill Color
galleries.
Alignment

Change horizontal or vertical cell alignment or
wrap text in cells.

On the Home tab, find alignment and text
wrapping options in the Alignment group.

Number Formatting

Select from 11 popular formats, such as
number, currency, percent, date, and text.
You can also increase and decrease the
number of decimal places in the number
format.

On the Home tab, find number formatting
options in the Number group.

Functions

Use many of the same functions that are in
Excel. When you begin to type a function
name, you see an IntelliSense list of available
functions.

Click in a worksheet cell. The IntelliSense list
for functions appears after you type the equal
sign followed by at least the first letter of the
desired function name.

Tables

Create an Excel table with sort and filter
capabilities, banded rows, and formatting
that automatically coordinates with the active
workbook theme. You can also add a header
row or total row to the table.

Select the cells in the worksheet to use as the
table range. Then, on the Home tab, in the
Tables group, click Sort & Filter as Table. Or
on the Insert tab, click Table.

As in Excel, when you type in the row directly
below the table range, the table automatically
expands. Additionally, when you add a
formula in a cell immediately to the right of
any table row, Excel Web App creates a
calculated column, expanding the table and
adding that formula to all other data rows in
the table.

For header row and totals row settings, on
the Home tab, in the Tables group, click Table
Options.
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Features and Benefits

Description

Where to Find

Edit Worksheet Structure

Insert and delete cells, rows, and columns on
the worksheet.

On the Home tab, in the Cells group, find the
Insert and Delete options.

Hyperlinks

Insert a hyperlink to a web address or apply a
link to selected text.

Click the Insert tab. In the Links group, click
Link.

Table 9 describes the features and benefits of PowerPoint Web App.
Table 9: Features and benefits of PowerPoint Web App
Features and Benefits

Description

Where to Find

Viewing in PowerPoint Web App
View and Copy Slide
Notes

View the notes pane for a slide with a single
click, or copy note text directly from
PowerPoint Web App View mode.

Click the Notes button on the status bar in
PowerPoint Web App View mode. Drag to
select notes, and then use the CTRL+C
keyboard shortcut to copy the notes.

Run Slide Show

Run a slide show in the browser in high
fidelity. PowerPoint Web App supports many
of the animations that can be applied in
PowerPoint on the desktop.

On the command bar, click Start Slide Show.

Navigation

Use Previous Slide and Next Slide buttons to
easily browse slides, or click the slide number
indicator to see a list of slides and move
directly to the desired slide.

In View mode, in the center of the status bar,
find the Previous Slide and Next Slide buttons
and slide number indicators.

Broadcast Slide Show

Broadcast Slide Show is a new feature of
PowerPoint 2010 that uses PowerPoint Web
App to run a slide show live for a remote
audience.

PowerPoint 2010 is required to broadcast a
slide show to a remote audience through
PowerPoint Web App.

Note: To run a slide show when editing a
presentation in PowerPoint Web App, click
the View tab, and then click Slide Show.

Viewers can watch live presentations through
PowerPoint Web App, regardless of whether
they have PowerPoint installed.
Note: Viewing the broadcast requires an
Internet connection and a supported browser
(for example, Internet Explorer, Firefox, or
Safari).

Outline View

View, copy, or print the text outline of slide
titles and text.

On the command bar, click File, and then click
Outline View.
To copy or print outline text, drag to select
text and then right-click the selected text for
the browser’s copy and print options.

Open in PowerPoint

With a single click, you can continue editing a
presentation in PowerPoint on the desktop.

In PowerPoint Web App View mode, find
Open in PowerPoint on the command bar or
by clicking the File tab.
Note: In PowerPoint Web App Edit mode, find
this command on the Home tab, in the Office
group.
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Features and Benefits

Description

Where to Find

Edit in Web App

When viewing a presentation in PowerPoint
Web App View mode, open the presentation
for editing in the browser with a single click.

On the command bar, click Edit in Browser.

Editing in PowerPoint Web App
Save

When you open a presentation for editing in
PowerPoint Web App, the presentation is
automatically saved as you work.

Saving is automatic in PowerPoint Web App.

View and Edit Slide Notes

The default editing view in PowerPoint Web
App displays the notes pane at the bottom of
the screen. Click in the pane to add or edit
slide notes.

To show or hide the notes pane, click the
View tab, and then click Notes.

View in Web App

When editing a presentation in PowerPoint
Web App, you can switch views to review
slides in View mode.

On the ribbon, click the View tab, and then
click Reading View.

Clipboard

Cut, copy, and paste content in a
presentation. A user can copy and paste text
between Web Apps, as well as between Office
Web Apps and the Microsoft Office programs
on the computer.

On the Home tab, in the Clipboard group, find
the Cut, Copy, and Paste commands.

Undo or redo an infinite number of recent
actions during the current editing session in
the active presentation.

On the Quick Access Toolbar, click the Undo
and Redo buttons.

Note: If the editing session times out or if you
switch to Reading View for more than 30
seconds, the undo history is reset.

You can also use the CTRL+Z (undo) and
CTRL+Y (redo) keyboard shortcuts.

Create and Manage Slides

Insert a new slide with the choice of any slide
layout available in the active presentation.
You can also delete, duplicate, or hide slides
with one click.

On the Home tab, find all slide management
options in the Slides group.

Font Formatting

Apply font, font size, and font color, as well as
bold, italic, and underline attributes.

On the Home tab, find all font formatting
options in the Font group.

Undo and Redo

Note: You can also use the keyboard
shortcuts: CTRL+C (copy), CTRL+X (cut), and
CTRL+V (paste).

Note: Active theme colors are available for
text in PowerPoint Web App. Find the active
theme colors in the Font Color gallery.
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Features and Benefits

Description

Where to Find

Alignment, Bullets, and
Numbering

Change paragraph alignment, apply bullets or
numbering, and change the level of bulleted
or numbered text.

On the Home tab, find alignment and bullets
and numbering options in the Paragraph
group.
You can also use the TAB and SHIFT+TAB
keyboard shortcuts at the beginning of a
bulleted or numbered paragraph to change
list level.
Note: When you click in a bulleted or
numbered text box to edit it, the bullet and
numbering styles appear with default
formatting while editing. To see the custom
bullet or number formatting, click outside of
the placeholder.

Pictures

Insert a picture into any picture or content
placeholder on a slide. You can also replace
an existing picture and apply picture styles.

To insert a picture, click the picture icon in an
empty placeholder. You can also click the
Insert tab, and then click Picture.
When you select a picture, the Picture Tools
Format tab provides the options to replace
the picture or apply a picture style.
Note: The Picture option on the Insert tab is
available whenever the active slide contains
an available picture placeholder.

SmartArt

Add, edit, and format SmartArt graphics in a
presentation. SmartArt graphics can help you
create professional-quality diagrams—such as
organization charts and radial diagrams—just
by typing a bulleted list.

To insert a SmartArt graphic, click the
SmartArt icon in an empty content
placeholder.
You can also click the Insert tab, click
SmartArt, and then click to select a layout.
When you select a SmartArt graphic, the
SmartArt Tools tab lets you apply formatting
styles and colors or to change the diagram
layout.
Click in a SmartArt graphic, and the SmartArt
text pane appears automatically. Edit diagram
text in this pane, or add and delete bullets in
this pane to add or delete shapes from your
graphic.
Note: The SmartArt option on the Insert tab is
available whenever the active slide contains
an available content placeholder.

Hyperlinks

Insert a hyperlink to a web address or apply a
link to selected text.

On the Insert tab, in the Links group, click
Link.
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Table 10 describes the features and benefits of OneNote Web App.
Table 10: Features and benefits of OneNote Web App
Features and Benefits

Description

Where to Find

Instantly see who made specific changes in a
notebook.

On the command bar, click Show Authors.

View previous versions of notebook pages. A
page version is saved when someone makes
changes in a shared notebook.

To view previous page versions, right-click the
page tab, and then click Show Versions.

Navigation

Click a section name to view all pages in that
section, and then click a page tab to view the
page.

A navigation pane appears to the left of the
page when viewing or editing in OneNote
Web App. This pane displays the sections and
pages of the active notebook.

Open in OneNote

With one click, you can continue editing a
notebook in OneNote on the desktop.

In OneNote Web App View mode, find Open
in OneNote on the command bar or by
clicking the File tab.

Viewing in OneNote Web App
Show Authors

View Previous Page
Versions

Note: When editing in OneNote Web App,
this feature is available on the View tab.

Note: To restore or delete previous page
versions, open the notebook for editing in
OneNote Web App.

Note: When editing a notebook in OneNote
Web App, find this command on the Home
tab, in the Office group.
Edit in Web App

When editing a notebook in OneNote Web
App, you can switch between Edit and View
modes.

On the command bar, click Edit in Browser.

Features and Benefits

Description

Where to Find

Save

Saving edits in OneNote Web App is
automatic, just as in OneNote on the desktop.

Changes are automatically saved you edit in
OneNote Web App.

View in Web App

When viewing a notebook in OneNote Web
App, you can switch between Edit and View
modes.

On the ribbon, click the View tab, and then
click Reading View.

Co-authoring for Shared
Notebooks

Simultaneously edit notebooks with people in
other locations who are using either OneNote
Web App or OneNote 2010.

Open a notebook for editing in OneNote Web
App. When someone else opens the same
notebook for editing in OneNote Web App or
OneNote 2010, simultaneous editing begins
automatically.

Editing in OneNote Web App

Note: See changes that others make
automatically. Changes synchronize in near
real time.
Clipboard

Cut, copy, and paste content in a notebook.
You can copy and paste text between Web
Apps, as well as between Office Web Apps
and the Microsoft Office programs on the
computer.

On the Home tab, in the Clipboard group, find
the Cut, Copy, and Paste commands.
Note: You can also right-click the selected
content and then click Cut, Copy, or Paste
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Features and Benefits

Description

Where to Find

Undo and Redo

Undo or redo recent actions for each page
that is edited in the active notebook.

On the Quick Access Toolbar, click the Undo
and Redo buttons.

Note: OneNote Web App gives you a separate
undo history for each page edited in the
active notebook. You can undo an infinite
number of actions per page during the
current editing session—until either a picture
is inserted or an edit is received from another
author. Note also that moving and deleting
pages cannot be undone.

You can also use the CTRL+Z (undo) and
CTRL+Y (redo) keyboard shortcuts.

Font Formatting

Apply font, font size, and several font
formatting attributes—including bold, italic,
underline, and superscript. You can also
highlight text, change font color, and clear
formatting on selected text.

On the Home tab, find all font formatting
options in the Basic Text group.

Paragraph Formatting

Change paragraph alignment, increase or
decrease the indent from left margin, or
change text direction from left to right.

On the Home tab, find paragraph formatting
options in the Basic Text group. Text direction
is available from the Paragraph Alignment
drop-down list.

Bullets and Numbering

Apply a choice of three bullet styles or five
numbering styles. Use the Increase Indent
and Decrease Indent buttons to change the
list level for existing bulleted and numbered
lists in a notebook, as well as those created in
OneNote Web App.

On the Home tab, find bullets, numbering,
and the options to change list level in the
Basic Text group.

Styles

Easily apply text styles for quick formatting.

Find text styles on the Home tab, in the Styles
group.
Note: You can also use keyboard shortcut
keys, including CTRL+ALT+1, 2, and 3 (apply
Heading styles) and CTRL+SHIFT+N (apply
Normal style).

Tags

Apply a variety of tags to notes for easy
organization and follow-up (for example,
flagging notes as questions, to-do items,
contact information).

On the Home tab, in the Tags group, click Tag.

Proofing Tools

OneNote Web App automatically checks
spelling as users type and applies a wavy red
underline to misspelled text. Common
AutoCorrect actions are included, such as
correcting routine misspellings or converting
characters to symbols.

On the Home tab, in the Spelling group, click
Spelling to move to the next spelling error on
the page. A drop-down list of correction
options appears. You can also right-click a
misspelled word to access correction options.

Additionally, you can set the proofing
language or turn off the spelling checker for
selected text.

On the Home tab, click the arrow beneath the
Spelling button for Set Proofing Language to
change the proofing language or disable the
spelling checker.

Microsoft Office Web Apps Service Description

29

Features and Benefits

Description

Where to Find

Create and Manage Pages
and Sections

Easily add or delete pages and sections,
rename sections, and demote or promote
subpages.

Click the New Page icon in the navigation
pane to add a page.
You can also click the Insert tab, and in the
Notebook group, click New Page or New
Section.
Right-click a section tab to rename or delete
the section.
Right-click a page tab to delete the page or to
increase or decrease the indent (in order to
create subpages).

View and Restore Page
Versions

Pictures

Tables

A page version is saved when someone makes
changes in a shared notebook. When a
notebook is open for editing in OneNote Web
App, you can view, restore, or delete previous
page versions.

Click the View tab, and then click Page
Versions.

Insert a picture from a file or from Office.com
Clip Art. You can also resize pictures and add
alternative text.

To insert a picture, click the Insert tab. In the
Picture group, click Picture or click Clip Art.

Insert a table, edit table text, and easily edit
basic table structure, such as adding or
deleting rows and columns.

To insert a table, click the Insert tab. In the
Tables group, click Table. Then, point to the
grid to select the desired number of columns
and rows, and then click to insert.

After selecting a previous page version, you
will see a notification bar at the top of the
page indicating that the page is a read-only
previous page version. Click the bar for the
option to delete or restore the active page
version.

To resize a picture or add alternative text,
select the picture. The Picture Tools Format
tab provides these options whenever you
select a picture.

To edit table structure, click in a table. The
Table Tools Layout tab appears automatically,
providing options to select, delete, and insert
table elements and to align content in cells.
You can also right-click in a table for table
editing options.
Hyperlinks

Insert a hyperlink to a web address or apply a
link to selected text.

Click the Insert tab. In the Links group, click
Link.
Note: You can also right-click a page tab to
copy a direct link to that page.

Placeholders

OneNote Web App Edit mode automatically
displays placeholders for features it cannot
display, such as equations and digital ink.
Placeholders preserve the layout and rich
content in a notebook and help users
navigate a file when making edits in OneNote
Web App.

To view the rich content that is shown as
placeholders in OneNote Web App Edit mode,
click the View tab, and then click Reading
View.
You can also click the Home tab, and then
click Open in OneNote.
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Appendix A: Versions of Office Web Apps
Table 11 describes the Office Web Apps features available in Windows Live, Office 365 and for onpremises users.
Table 11. Feature comparison for Office Web Apps version
Windows Live

Office 365

On-Premises

Audience

Consumers

Organizations

Organizations

Storage

Windows Live SkyDrive

SharePoint Online

SharePoint 2010

Authentication

Windows Live ID

IT-managed

IT-managed

Pricing

Free (with ads)

Determined by the Office 365
plan

Office 2010 volume licensing

Ad Supported



SharePoint Experience





IT Administration
Control





Document Life Cycle
Management





AD Interoperability





Auditing





®

Windows Live Hotmail
Interoperability



SLA

N/A

Support

N/A

Supported Browsers

Internet Explorer 7 and later

Internet Explorer 7and later

Internet Explorer 7and later

Firefox 3.5 and later

Firefox 3.5and later

Firefox 3.5 and later

Safari 4 and later

Safari 4 and later

Safari 4 and later

Chrome 3 and later

Note

View the full list of supported browsers in the System Requirements section.
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